Slow Data Display on Connect

Incident Report for Blaxtair Apps

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:31 CET

Investigating

The data is displayed on Connect, but it loads very slowly. Each page takes a long time to appear and we are currently investigating the source of the issue.
Posted Dec 04, 2025 - 15:38 CET
This incident affected: Blaxtair Apps (Dashboard).